fbpx

Dcoumentation for Ecommerce

Requirements

Our main goal at Elementor is to create the fastest, most advanced page builder for WordPress.
To achieve this, we make sure it is based on the latest technology available.

Here are the system requirements you need in order to use Elementor.
(If you are not sure whether or not your server support this, contact your host).
WordPress 4.7 or Greater
Elementor works with WordPress version 4.7 or greater